Напишите программу в паскале: удалить из массива последний четный элемент

0 голосов
57 просмотров

Напишите программу в паскале:
удалить из массива последний четный элемент


Информатика (35 баллов) | 57 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2 сборка 1318


Const
  n=5;

  Var
  ar:array[1..n] of integer;
  i,indf:integer;
begin
indf:=-1;
for i:=1 to n do
  begin
    readln(ar[i]);
    if not(odd(ar[i])) then indf:=i;
  end;
if indf=-1 then
  writeln('Нет чётных')
 else
  begin
    for i:=indf to n-1 do
      ar[i]:=ar[i+1];
    for i:=1 to n-1 do
      write(ar[i]:4);
  end;
end.

Пример ввода:
1 2 3 4 5
Пример вывода:
1 2 3 5

(38.6k баллов)