Напишите программу, которая вычисляет сумму элементов матрицы. Входные данные В первой...

0 голосов
192 просмотров

Напишите программу, которая вычисляет сумму элементов матрицы.

Входные данные
В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами.

Выходные данные
Программа должна вывести одно число – сумму элементов матрицы.


Информатика (15 баллов) | 192 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
   S:real;
   N,M:integer;
Begin
Read(N,M);
S:=0;
For N:= 1 to N*M do
    Begin
    Read(M);
    S:=S+M
    End;
WriteLn('S = ',S);
End.

(34.0k баллов)