Решить в паскале : Написать программу решения квадратного уравнения

0 голосов
56 просмотров

Решить в паскале :
Написать программу решения квадратного уравнения


Информатика (36 баллов) | 56 просмотров
0

Вы проходите это в 10-11 классах?!

Дан 1 ответ
0 голосов

Program QuadraticEquation;
  Var a, b, c, d, x1, x2:real;
Begin
      Writeln('vvedite a, b, c');
      Readln(a,b,c);
      If A=0 then
           Writeln('algoritm ne primenim');
      D:=b*b-4*a*c;
      If D<0 then<br>           Writeln('deystvit resheniy net');
      If D=0 then
           Begin
                  x1:=-b/(2*a);
                  Writeln('x1=',x1);
           End
      Else
           Begin
                  x1:=(-b+sqrt(D))/(2*a);
                  x2:=(-b-sqrt(D))/(2*a);
                  Writeln('x1=',x1, 'x2=', x2);
           End;
end.
               Держи!)

(334 баллов)