Составьте программу,которая выводит ** экран число сотен в заданном числе, если оно...

0 голосов
77 просмотров

Составьте программу,которая выводит на экран число сотен в заданном числе, если оно трёхзначное, а в противном случае сообщает: "число не трёхзначное" .


Информатика (33 баллов) | 77 просмотров
Дан 1 ответ
0 голосов

Решение на С/C++ :

#include
using namespace std;
int main()
{
int number;
cin>>number;
number=(number-number%10)/10;
//в результате остаётся число десятков, т.е. число без единиц
number=(number-number%10)/10; // тут уже число сотен без десятков
if(number==0) // если в результате будет 0 десятков, то выводим текст
{
cout<<"chislo ne trehznachnoe";<br>}
else // в противном случае десятки будут
{
cout<<number; // и выводим их кол-во <br>}
return 0;
}

(76 баллов)