Написать программу в PASCAL начисления скидок: если сумма покупки > 100, то скидка 10%....

0 голосов
106 просмотров

Написать программу в PASCAL начисления скидок: если сумма покупки > 100, то скидка 10%. Если меньше или равна 100, то скидка 5%


Информатика (44 баллов) | 106 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var s:real;
begin
write('Сумма покупки = ');
readln(s);
if s>100 then writeln('Скидка = ',s*0.1)
else writeln('Скидка = ',s*0.05);
end.

Пример:
Сумма покупки = 200
Скидка = 20

(194k баллов)
0

спасибо

0

Пожалуйста.

0 голосов

Program программаначисленияскидок;
var
a: real;
begin
writeln('Введите сумму покупки.');readln(a);
if a > 100 thenwriteln('Предоставляется скидка 10%.')elsewriteln('Предоставлется скидка 5 %.');
end.

(326 баллов)
0

после "then", "else", ";" с новой строки продолжается

0

спасибо