Напишите программу, которая выводит все простые числа в диапазоне от 2 до N ( N заранее...

0 голосов
175 просмотров

Напишите программу, которая выводит все простые числа в диапазоне от 2 до N ( N заранее неизвестно).

Входные данные
Входная строка содержит целое число N .

Выходные данные
Программа должна вывести все простые числа в диапазоне от 2 до N в одну строку, разделив их пробелами.

Примеры
входные данные
20
выходные данные
2 3 5 7 11 13 17 19


Информатика (15 баллов) | 175 просмотров
0

Паскаль?

Дан 1 ответ
0 голосов
Правильный ответ

Var
A,N,d:integer;
Begin
Write('N = ');ReadLn(N);
For N:= 2 to N do
    Begin
    d:=0;
    A:=2;
    Repeat
    if N mod A = 0 then d:=d+1;
    A:=A+1
    Until A>Sqrt(N)+1;
    if d = 0 then Write(N,' ')
    End
End.

(34.0k баллов)