75 БАЛЛОВ ЗА ЛУЧШИЙ ОТВЕТ!!! Составить программу для следующих задач: 1)По номеру для...

0 голосов
62 просмотров

75 БАЛЛОВ ЗА ЛУЧШИЙ ОТВЕТ!!!
Составить программу для следующих задач:
1)По номеру для недели выводит на экран расписание уроков на этот день
2)Определить является ли данное число четным
3)Определить число,полученное выписыванием в обратном порядке цифр заданного целого трехзначного числа


Информатика (448 баллов) | 62 просмотров
0

Паскаль?

0

Да

0

ABC ?

0

Pascal: turbo, free, ABC, Delphi ?)

0

Не разбираюсь в этом вообще)для школы нужно

0

Знаю только то,что с Program,Var,Begin,Writeln и т.д. а turbo там или free, ABC, Delphi без понятия

0

То есть, в школе не сказали, на каком Паскале пишите? Ладно..

0

Не сказали..

Дан 1 ответ
0 голосов
Правильный ответ

Var
N:integer;
Begin
WriteLn('Введите номер дня недели');
Read(N);
Case N of
1:
  Begin
  WriteLn('Чтение');
  WriteLn('Труд');
  WriteLn('Музыка');
  WriteLn('Физ-ра');
  End;
2:
  Begin
  WriteLn('Изо');
  WriteLn('Русский');
  WriteLn('Математика');
  WriteLn('Окружающий мир');
  End;
3:
  Begin
  WriteLn('Геометрия');
  WriteLn('Краеведенье');
  WriteLn('География');
  WriteLn('МХК');
  End;
4:
  Begin
  WriteLn('ОБЖ');
  WriteLn('Информатика и ИКТ');
  WriteLn('Физика');
  WriteLn('Химия');
  End;
5:
  Begin
  WriteLn('Биология');
  WriteLn('История');
  WriteLn('Обществознание');
  WriteLn('Алгебра');
  End;
6:  
  Begin
  WriteLn('----------');
  WriteLn('Литература');
  WriteLn('Черчение');
  End;
7:
  Begin
  WriteLn('Воскресенье!!!');
  End;
End;

End.




Var
A:integer;
Begin
Write('A = ');ReadLn(A);
if A mod 2 = 0 then WriteLn(A,' - чётное число')
else WriteLn(A,' - нечётное число')
End.




Var
A:integer;
Begin
WriteLn('Введите трёхзначное число');
ReadLn(A);
WriteLn(A mod 10,(A div 10) mod 10,A div 100);
End.


(34.0k баллов)
0

Спасибо огромное!)