Помогите написать программу-найти в массиве из 5 целых чисел номера отрицательных...

0 голосов
16 просмотров

Помогите написать программу-найти в массиве из 5 целых чисел номера отрицательных элементов(вывести их на экран), если таких нет, то сообщить об этом


Информатика (93 баллов) | 16 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(5,-20,20); a.Println;
  var s:=a.Select((x,i)->(x,i)).Where(k->k[0]<0);<br>  if s.Count>0 then s.Select(k->k[1]+1).Println
  else Writeln('Отрицательных элементов нет')
end.

Пример
-6 -16 20 7 -19
1 2 5

(150k баллов)
0 голосов

#include
#include
#include

int main(int argc, char *argv[])
{
system("chcp 1251 >nul");
setlocale(LC_ALL, "Russian");
srand(time(NULL));

int mass[5];
bool op;

printf("Заполнить массив самостоятельно? (1/0): ");
scanf("%d", &op);
for(int i = 0; i < 5; i++){
if(op){
printf("Введите %d-е число: ", i+1),
scanf("%d", &mass[i]);
}else mass[i] = (rand() % 200) - 100;
}
std::cout << std::endl;<br> int sm = 0;
for(int i = 0; i < 5; i++)
if(mass[i] < 0) printf("%d-й элемент отрицательный: %d\n", i+1, mass[i]), sm++;
if(!sm) printf("В массиве нет отрицательных чисел.");

return EXIT_SUCCESS;
}

(302 баллов)
0

Тем не менее, мой учитель разрешает писать мне на Си. Но и тот, кто задал вопрос, не уточнил про ЯП.

0

В таких ситуациях я использую Паскаль, но все же мне ближе Си.