Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней...

0 голосов
198 просмотров

Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212).

Входные данные
Входная строка содержит одно натуральное число.

Выходные данные
Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, и слово 'NO', если такой пары цифр нет.

Примеры
входные данные
212
выходные данные
YES
входные данные
12345
выходные данные
NO

На паскале, пожалуйста.


Информатика (34 баллов) | 198 просмотров
0

Case можно использовать?

0

Можно

0

И массив можно,?

Дан 1 ответ
0 голосов
Правильный ответ

Var A:integer;
C:array[0..9] of integer;
Begin
ReadLn(A);
While A<>0 do
   Begin
   C[A mod 10]:=C[A mod 10]+1;
   A:= A div 10;
   End;
While (A<9)and(C[A]<2) do A:=A+1;<br>if C[A]>1 then WriteLn('YES')
else WriteLn('NO');
End.

(34.0k баллов)