1.Cоставить программу,которая заполняет квадратную матрицу 9 х 9. 1 1 1 1 ...1 2 2 2...

0 голосов
61 просмотров

1.Cоставить программу,которая заполняет квадратную матрицу 9 х 9.

1 1 1 1 ...1
2 2 2 2...2
3 3 3 3...3
...
9 9 9 9...9

2.Составить программу решения поставленной задачи.
В прямоугольной матрице отрицательные числа заменить им противоположными.


Информатика (152 баллов) | 61 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1425 от 22.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=MatrGen(9,9,(i,j)->i+1); a.Println(2);
end.

Результат
 1 1 1 1 1 1 1 1 1
 2 2 2 2 2 2 2 2 2
 3 3 3 3 3 3 3 3 3
 4 4 4 4 4 4 4 4 4
 5 5 5 5 5 5 5 5 5
 6 6 6 6 6 6 6 6 6
 7 7 7 7 7 7 7 7 7
 8 8 8 8 8 8 8 8 8
 9 9 9 9 9 9 9 9 9

begin
  var n:=ReadInteger('Количество строк в матрице:');
  var m:=ReadInteger('Количество столбцов в матрице:');
  Writeln('*** Исходная матрица [',n,',',m,'] ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  Writeln('*** Результат [',n,',',m,'] ***');
  a.Fill((i,j)->Abs(a[i,j])); a.Println(4)
end.

Пример
Количество строк в матрице: 4
Количество столбцов в матрице: 7
*** Исходная матрица [4,7] ***
  10  42   3  83 -65  43  65
 -52 -40  55  75 -27  53 -47
  17  88  93  32  35  41 -76
  70  13   6   2   9 -22 -55
----------------------------
*** Результат [4,7] ***
  10  42   3  83  65  43  65
  52  40  55  75  27  53  47
  17  88  93  32  35  41  76
  70  13   6   2   9  22  55
(150k баллов)