Программа получает ** вход целые числа, не равные 0. Количество введенных чисел...

0 голосов
91 просмотров

Программа получает на вход целые числа, не равные 0. Количество введенных чисел неизвестно, последовательность чисел заканчивается 0. Введенные числа по модулю не превышают 30000. Программа должна ответить на вопрос: верно ли, что максимальное из чисел превышает минимальное больше чем в 2 раза?


Информатика (132 баллов) | 91 просмотров
0

Паскаль? Бейсик? Си?

0

Паскаль

Дан 1 ответ
0 голосов
Правильный ответ

Var A,Max,Min:integer;
Begin
ReadLn(A);
Max:=A;
Min:=A;
While A<>0 do
   Begin
   ReadLn(A);
   if A>Max then Max:=A;
   if A   End;
WriteLn(Max/Min > 2)
End.

(34.0k баллов)