Решать ** Pascal ABC.net версия 3.2 сборка 1417. Написать программу, которая выполняет...

0 голосов
54 просмотров

Решать на Pascal ABC.net версия 3.2 сборка 1417. Написать программу, которая выполняет сравнение многоразрядных десятичных ЦЕЛЫХ чисел. То-есть вывести > если первое число больше второго; вывести < если второе число больше первого; вывести = если числа равны.


Информатика (94 баллов) | 54 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017

begin
  var a:=ReadlnString('1-е число:').ToBigInteger;
  var b:=ReadlnString('2-е число:').ToBigInteger;
  if a>b then Writeln('>')
  else
    if a=b then Writeln('=')
    else Writeln('<')<br>end.

Пример
1-е число: 45685695606778795409839437392759354
2-е число: 8643603434233452532223423423525
>

Замечание: разрядность чисел - произвольная.
(150k баллов)
0 голосов

Var a,b:uint64;
Begin
Write('Введите два целых числа: ');ReadLn(a,b);
if a > b then Write(a,' > ',b)
else if a < b then Write(a,' < ',b)
     else Write(a,' = ',b)
End.

(34.0k баллов)
0

Я же написал!Многоразрядных десятичных чисел!Ответ удалят

0

"Многоразрядные" подразумевает, что у числа больше одного разряда - И ВСЁ. Никакого другого ограничения, или обязательного условия на размер чисел нет

0

А если Вам нужно сравнивать числа конкретного типа - например, BigInteger - это надо в условии уточнять.

0

Ну, лично я этот термин три раза встречал, и мне никто толком не объяснял, что это именно произвольная разрядность. Кстати, в Вашей программе можно и без преобразования в BigInteger))