Напишите программу ** языке программирования Pascal. Дано натуральное число n, целые...

0 голосов
58 просмотров

Напишите программу на языке программирования Pascal. Дано натуральное число n, целые числа а₁, а₂, ..., a_{n} .Вычислить сумму чисел а₁, а₂, ..., a_{n}, кратных 3.


Информатика (829 баллов) | 58 просмотров
0

Полное условие задачи в студию!

0

Как я поняла, это и есть полное условие задачи. Потому что большего у меня не написано.

0

Ой, вот косяк

0

Все,исправила

Дан 1 ответ
0 голосов
Правильный ответ

Var n,i,k,s : integer;
Begin
  s:=0;
  Write('N ? '); Readln(n);
  Writeln('Вводите a1 a2 ... aN');
  For i:=1 to n do
  Begin
    Readln(k);
    If k mod 3 = 0 then s:=s+k;
  end;
  Writeln('Сумма кратных трём: ',s);
end.

(5.1k баллов)