Помогите с информатикой! Нужно написать программу в Паскаль ABC "Линейные алгоритмы....

0 голосов
43 просмотров

Помогите с информатикой! Нужно написать программу в Паскаль ABC "Линейные алгоритмы. Решение задач"
1.Мальчик может бегать в 3 раза быстрее, чем ходить. Скорость его ходьбы составляет А км/час. Мальчик принял участие в марафонском забеге, но сошел с дистанции, пробежав Х км. Сколько времени он затратил?
2. Цех по ремонту бытовой техники имеет ежедневно прибыль Р, с которой платит налог 70%. Из оставшейся доли прибыли 30% идет на развитие производства, а остальное - на заработную плату 8 работникам. Какова заработная плата работника за месяц?


Информатика (14 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

1) program znanija2;
var speed, A, X:integer;
    time:real;
begin
  readln(A);
  readln(X);
  speed:= A * 3;
  time:= X / speed;
  writeln(time);
end.


2)


program znanija3;
var P:integer;
    tax, rest, wages, answer:real;
begin
  read(P);
  tax:=(P*70)/100;
  rest:= P - tax;
  wages:= (rest*70)/100;
  answer:= wages / 8;
  writeln(answer);
end.



(3.4k баллов)