Помогите написать программу в pascal. Найдите сумму всех целых чисел [a;b]Заранее спасибо.

0 голосов
22 просмотров

Помогите написать программу в pascal.
Найдите сумму всех целых чисел [a;b]Заранее спасибо.


Информатика (163 баллов) | 22 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a,b:integer; Read(a,b);
  Writeln('S=',Range(a,b).Sum)
end.

Пример
8 42
S=875
(150k баллов)
0 голосов

Var
   a,b:integer;
   S:real;
Begin
S:=0;
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
For b:= a to b do
    S:=S+b;
WriteLn('S = ',S);
End.

(6.6k баллов)