Написать программу для возведения в степень

0 голосов
31 просмотров

Написать программу для возведения в степень


Информатика (32 баллов) | 31 просмотров
Дан 1 ответ
0 голосов
Program p_2;
Var 
  z, a : Real; m : integer;
Function Step (n: integer; x:real): real;
Var 
  i: integer; y: Real;
    Begin
      i:=1; y:=1;
      While i<=n do<br>        Begin
          y:=y*x; I:=I+1;
        End;
          Step:=y;
      End;
 {Конец функции}
Begin
   Write(‘Введи степень и возводимое число’); Readln(Z,M);
   F:=Step(m,z);
   Writeln(z, ‘ в степени’, m, ‘=’,f);
End.

(7.7k баллов)