Помогите с информатикой Напишите программу, которая запрашивает четырёхзначное число,...

0 голосов
175 просмотров

Помогите с информатикой

Напишите программу, которая запрашивает четырёхзначное число, разрезает его пополам и выводит половинки через пробел.
Sample Input 1:
1234
Sample Output 1:
12 34
Sample Input 2:
1200
Sample Output 2:
12 00
Напишите программу, которая запрашивает пятиразрядное число и выводит число, составленное из цифр данного числа взятых задом наперёд.
Sample Input 1:
12345
Sample Output 1:
54321
Sample Input 2:
12000
Sample Output 2:
21


Информатика (155 баллов) | 175 просмотров
0

На каком языке?

0

code blocks

0

с++

0

#include using namespace std;int main() { int a, b, c, d; cin >> a; b = a/100; c = a%100; cout << b << " " << c; return 0;}

Дан 1 ответ
0 голосов
Правильный ответ

#include using namespace std;int main() {  int a, b, c, d;  cin >> a;  b = a/100;  c = a%100;  cout << b << " " << c;  return 0;}<br>но есть проблема, переменные типа int сокращает 00 до 0
и на выводе получается не 12 00, а 12 0

(99 баллов)