Написать программу ** С++ 3. Известен факториал числа (вводится с клавиатуры). Найти это...

0 голосов
64 просмотров

Написать программу на С++ 3. Известен факториал числа (вводится с клавиатуры). Найти это число.


Информатика (819 баллов) | 64 просмотров
0

А ограничения какие-то есть?

0

Через вложенные циклы

0

For

Дан 1 ответ
0 голосов
Правильный ответ

1.
#include
using namespace std;

int main()
{
    int f, n, p;
    cin >> f;
    n = 0;
    p = 1;
    while (p    n++;
    p*=n;
    }
    if (p==f) cout << n;<br>    else cout << "Ошибка ввода";<br>    system("pause");
}

2.
#include
using namespace std;

int main()
{
    int f, n, p;
    cin >> f;
    p = 1;
    for (n=1; p    if (p==f) cout << n-1;<br>    else cout << "Ошибка ввода";<br>    system("pause");
}

Пример:
120
5

(194k баллов)