По программе Pascal.1)Напишите программу определяющую средний балл учащихся...

0 голосов
74 просмотров

По программе Pascal.
1)Напишите программу определяющую средний балл учащихся группы.
Программа должна спрашивать:
₋ сколько в группе человек,
₋ какой средний балл у каждого учащегося.
2) Написать программу, определяющий сколько тыс. руб. пропали сегодня в столовой из -за отсутствия на занятиях некоторых учащихся по неизвестной причине.
Программа должна спрашивать:
₋ сколько человек было поставлено на заявку,
₋ сколько человек присутствовало на занятиях,
₋ сколько стоит обед для одного учащегося.
3) Написать программу в которой будет меняться буква А на букву Б (слово можно любое подобрать, например ШАЛАШ)
4) Написать программу, определяющую количество банок краски, необходимых для покраски всех дверей в помещениях (например в квартире) .
Программа должна спрашивать:
₋ сколько в квартире дверей,
₋ какая высота и ширина в среднем у одной двери,
₋ сколько кв. метров можно прокрасить из одной банки.


Информатика (16 баллов) | 74 просмотров
0

Помогите пожалуйста, очень надо, прям ну очень....

Дан 1 ответ
0 голосов

Program next;
var a,b,c,i,g,o:integer;
begin
g:=0;
b:= 0;
writeln('Сколько учахщихся?');readln(a);
for i=0 to a do
writeln('Средний бал у ',i,' ученика:');readln(c);
g:= g+c;
end;
o:= g/a;
writeln('Средний балл учащихся',o);
readln;
end.

(16 баллов)
0

Ой, первое