ИНФОРМАТИКА ДАЮ 25 БАЛЛОВ НАПИШИТЕ ПРОГРАММУ ** 2 ПИТОНЕ длина Московской кольцевой...

0 голосов
34 просмотров
ИНФОРМАТИКА ДАЮ 25 БАЛЛОВ НАПИШИТЕ ПРОГРАММУ НА 2 ПИТОНЕ длина Московской кольцевой автомобильной дороги —109 километров. Байкер Вася стартует с нулевого километра МКАД и едет со скоростью v километров в час. На какой отметке он остановится через t часов?

Входные данные
Программа получает на вход значения v и t. Если v>0, то Вася движется в положительном направлении по МКАД, если же значение v<0, то в отрицательном.<br>
Выходные данные
Программа должна вывести целое число от 0 до 108 — номер отметки, на которой остановится Вася.

Примеры
входные данные
60
2
выходные данные
11
входные данные
-1
1
выходные данные
108


Математика (177 баллов) | 34 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Входные:60 и 2, выйти должно число 11.  Входные: -1 и 1, выйти должно 108.

Алгоритм:

С виду простая задача, но очень много условий должно выполняться:

Это «круг», то есть если число больше 109, то идем по второму кругу и т.д.Возможно движение в обратную сторонуДа и еще кучка…

Объяснять здесь нечего, главное не запутаться и выполнить все условия:D

Решение:

Решение на СИ:

#include int main() { int vasya,t,v,s; scanf("%d%d",&v,&t); if (v*t > 0) { vasya = (v * t) % 109; } else { if (v*t<=0) { vasya = (109 + ((v * t) % 109)) % 109; } } printf("%d", vasya); return 0; }<p> Решение на Паскале: var vasya,t,v,s:integer; begin readln(v,t); if (v*t>0) then begin vasya := (v * t) mod 109; end else if (v*t<=0) then begin vasya := (109 + ((v * t) mod 109)) mod 109; end; writeln(vasya); end.</span>
(130 баллов)
0

на ПИТООООНЕ