Написал программу ** паскале все правильно , но пишет какуйто ошибку .В общем помогите...

0 голосов
32 просмотров

Написал программу на паскале все правильно , но пишет какуйто ошибку .В общем помогите написать программу по схеме.


image

Информатика (20 баллов) | 32 просмотров
0

ну я так думал.... просто накосячил гдето

0

скинь прогу,я посмотрю? Потом скинь что пишет паскаль

0

можете так написать ? время мало , и я ту программу удалил

Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadReal2;
  if a<>0 then Writeln(-b/a)
  else
    if b<>0 then Writeln('Корней нет')
    else Writeln('Любое число')
end.

Примеры
4.2 -2.7
0.642857142857143

0 4
Корней нет

0 0
Любое число
(150k баллов)