Написать программу которая получает два целых числа и находит их произведение не...

0 голосов
139 просмотров

Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть отрицательными (pascal)


Информатика (15 баллов) | 139 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var a,b,p,i: integer;
z: byte;
begin
readln(a,b);
if ((a>0) and (b<0)) or ((a<0) and (b>0))then z:=1 else z:=2;
a:=abs(a);
b:=abs(b);
p:=0;
for i:=1 to a do p:=p+b;
if z=1 then write(-p) else write(p);
end.

(150k баллов)