Информатика 23 БАЛЛА! PASCAL Написать программу, которая сложит все натуральные числа от...

0 голосов
68 просмотров

Информатика
23 БАЛЛА!
PASCAL
Написать программу, которая сложит все натуральные числа от a до b. Например от 46 до 98.


Информатика (156 баллов) | 68 просмотров
0

Program suma;Var a, b, i, sum:integer;begin readln(a, b); for i:=a to b do sum:= sum + i; write(sum);end.

Дан 1 ответ
0 голосов
Правильный ответ

Var
i,a,b,s:integer;
begin
 write('Write a: '); readln(a);
 write('Write b: '); readln(b);
 s:=0;
 for i:=a to b do
  s:=s+i;
 writeln(s);
end.

(5.8k баллов)