Написать программу замещения первой половины строки второй а второй первой в с++

0 голосов
26 просмотров

Написать программу замещения первой половины строки второй а второй первой в с++


Информатика (36 баллов) | 26 просмотров
Дан 1 ответ
0 голосов

#include
#include

using namespace std;

int main()
{
    string a;
    char temp;
    cin >> a;
    for (int i = 0; i < a.size() / 2; ++i) {
        temp = a[i];
        a[i] = a[a.size() / 2 + i];
        a[a.size() / 2 + i] = temp;
    }
    cout << a;<br>}


(3.4k баллов)