Дан программный код: program my3; var N:longint; A,С:integer; begin writeln ('введите...

0 голосов
73 просмотров

Дан программный код: program my3; var N:longint; A,С:integer; begin writeln ('введите двузначное число:'); readln(N); A:= N div 100; C:= N mod 10; if (A=7) or (C=7) then N:= N*N; write(N); end. Каков результат работы программы при введении исходного числа N=17?


Информатика (83 баллов) | 73 просмотров
Дано ответов: 2
0 голосов

Результат будет равен 289


image
(324 баллов)
0

Спасибо!

0

А с этим не поможешь? Чему будет равно значение переменной X после выполнения последовательности операторов присваивания?
x: = 5;
y: = x* 2;
x: = y * y + y;
x: = x + y;

0

А всё, разобралась, не надо.

0

var x,y:integer;
begin

x:=5;
y:=x*2;
x:=y*y+y;
x:=x+y;

write('Результат:',y);{Результат 10}
end.

0 голосов

Не можно было просто переписать код в паскаль?


image
(5.8k баллов)