1.Напишите программу, которая выводит ** экран все простые числа в диапазоне от 1 до...

0 голосов
79 просмотров

1.Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры.
2.Напишите функцию, которая находит наибольший общий делитель для двух заданных чисел.


Информатика | 79 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
1)
var n,i:integer;
begin
Read(n);
for i:=1 to n do
 write(i,' '); 
end.

2) Функция:
 function nod(a, b: Integer): Integer;
Var t: Integer;
Begin
    If b > a Then
    Begin
        t := a;
        a := b;
        b := t;
    End;
    t := a;
    While t > 0 Do
    Begin
        Result := t;
        t := t- b;
    End;
End;



image
image
(5.8k баллов)
0

Спасибо.

0

А этот пример использование функции писать

0

По желанию, как учитель просил

0

но это точно правильно?

0

просто понимаешь я иду на все 5

0

можете проверить..

0

и прошу чтобы зделали информатику потому что я пишу сочинение на 400 слов

0

не некогда проверять

0

...

0

Сейчас добавлю скриншоты работы