Составьте программу которая находит сумму цифр трех значного числа ** PascalABC

0 голосов
36 просмотров

Составьте программу которая находит сумму цифр трех значного числа на PascalABC


Информатика (15 баллов) | 36 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Program n1;
var a: integer;
begin
readln(a);
a:=abs(a);
write((a div 100)+ (a mod 10)+ (a mod 100 div 10));
end.

(150k баллов)
0 голосов

Var
i,n,s: Integer;
begin
write('Введите трехзначное число ');
read(n);
i:=0;
while (n<>0) Do
begin
s :=n Mod 10;
i:=i+s;
n:= n Div 10;
end;
writeLn('Сумма цифр  : ',i)
end.

(840 баллов)