Даны целые числа А В Составить программу которая выводит квадрат суммы чисел если число А...

0 голосов
46 просмотров

Даны целые числа А В Составить программу которая выводит квадрат суммы чисел если число А делится на число В без остатка в противном случае - квадрат числа


Информатика (30 баллов) | 46 просмотров
0

Питон пойдет?

Дан 1 ответ
0 голосов

Vara,b:integer;begin a:=ReadInteger('Введите a'); b:=ReadInteger('Введите b'); if a mod b=0 then begin  write(Sqr(a+b)) end; if a mod b<>0 then begin write(SQR(a)) end; end. 

(1.4k баллов)
0

Var
a,b:integer;
begin
a:=ReadInteger('Введите a');
b:=ReadInteger('Введите b');
if a mod b=0 then begin
write(Sqr(a+b))
end;
if a mod b<>0 then begin
write(SQR(a))
end;
end.