Составить программу ** Паскале поиска и вывода всех простых чисел от 2 до 100. Проверкой...

0 голосов
56 просмотров

Составить программу на Паскале поиска и вывода всех простых чисел от 2 до 100.
Проверкой каждого числа из этого интервала на простоту.
При этом НЕ использовать решето Эратосфена.
И НЕ это, но что-то похожее)):
for i:=1 to n do
begin
j:=2;
lim:=round(sqrt(i));
while (i mod j <> 0) and (j <= lim) do inc( j );<br> if (j > lim) then write( i,' ' );
end;


Информатика (15 баллов) | 56 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Как-то так:
VVVVVVVVVVVV

(3.7k баллов)
0

Var i, j, z:integer;
Begin
For i:=2 to 100 do
Begin
Z:=0;
For j:=2 to i div 2 do
If (i mod j=0) and (i<>2) then begin z:=1;break; end;
If z<>1 then writeln(i);
End;
Readln() ;
End.

0

??

0

Программа для turbo pascal

0

А моя не подходит?)

0

Подходит)