Срочно! информатика. Перевести ** Паскаль и написать программу для решения этого...

0 голосов
38 просмотров

Срочно! информатика. Перевести на Паскаль и написать программу для решения этого...


image

Информатика (28 баллов) | 38 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

Вариант 1

begin
  var (x,a):=ReadReal2('Введите х и a через пробел:');
  var y:real;
  if x<=0 then y:=2*Sin(Abs(x))<br>  else
    if x<=5 then y:=Sqrt(x)<br>    else
      if x<=10 then y:=2*x*x-Sqrt(x)<br>      else y:=Cos(2*x)/a;
  Writeln('Y=',y)
end.

Вариант 2

begin
  var (x,a):=ReadReal2('Введите х и a через пробел:');
  Writeln('Y=',
      x<=0 ? 2*Sin(Abs(x)) :<br>      x<=5 ? Sqrt(x) :<br>      x<=10 ? 2*x*x-Sqrt(x) : Cos(2*x)/a)<br>end.

Примеры
Введите х и a через пробел: 12.4 -3
Y=-0.315050171382724

Введите х и a через пробел: 5.8 1.156
Y=64.8716810842415
(150k баллов)
0 голосов

Попробуем
program lll;
var
x,x1:real;
res1,res2,res3,res4:real;
begin
readln(x);
x1:=abs(x);
if (x<0) then<br>begin
res1:=2*sin(x1)
end
else
if(x>0) then
if(x<=5) then<br>begin
res2:=sqrt(x);
end;
else
if (x>5)
then if (x<=10) then<br>res3:=2x*x-sqr(x);
end
else
res4:=cos(2*x)/a;
end;
end.

(158 баллов)
0

Лучше на С++, структура была бы другой! Получше... Но пока как-то так!

0

Да вот задали на паскале.... Вот сидел и плакал над ним...) пасибо)

0

Там проверьте еще точки с запятой... Я быстро писала, может где забыла поставить... бегины и энды сверьте...