Напишите программу в ABC Pascal.

0 голосов
16 просмотров

Напишите программу в ABC Pascal.


image

Информатика (3.1k баллов) | 16 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Program n1;
var x,f: real;
begin
readln(x);
if x<=0 then f:=0 else if (x>0) and (x<=1) then f:=x*x-x <br>else f:=x*x-sin(pi*x*x);
write(f);
end.

(150k баллов)
0

По моему в условии записано x^2 - sin(пи*x^2), или я не прав ?

0

Да, так написано.

0 голосов

Var x,y: real;
begin
  write('x = '); readln(x);
  y:=0;
  if x>1 then y:=x*x-sin(x*x*pi);
  if (x>0) and (x<=1) then y:=x*x-x;<br>  writeln('f(x) = ',y);
end.

(9.7k баллов)
0

Если в трансляторе нет константы pi, то вместо нее можно записать 6*arctan(1/sqrt(3))