Написать программу "Вычислить сумму ряда 1+1.5+2+2.5+3+3.5+ .. + 30"

0 голосов
221 просмотров

Написать программу "Вычислить сумму ряда
1+1.5+2+2.5+3+3.5+ .. + 30"


Информатика (32 баллов) | 221 просмотров
Дан 1 ответ
0 голосов

Program RowSum;
Const min = 1; a = 0.5; max = 30;
Var b, c: Real;
i: Integer;
Begin
b := a;
c := 0;
For i := min To max * 2 - 1 Do
Begin
b := b + a;
c := c + b;
End;
WriteLn('Сумма ряда равна ', c:5:2);
ReadLn;
End.

(2.8k баллов)