Toggle navigation
Все ответы
Имя пользователя или адрес электронной почты
Пароль
Запомнить
Вход
Регистрация
|
Я забыл свой пароль
Вопросы
Горячее!
Без ответов
Категории
Задать вопрос
Задача по информатике
0
голосов
20
просмотров
Задача по информатике
задача
информатике
5 - 9 классы
информатика
Информатика
Farzaney_zn
(
19
баллов)
28 Май, 18
|
20
просмотров
ответить
комментировать
Ваш комментарий к вопросу:
Отображаемое имя (по желанию):
Напишите мне, если после меня будет добавлен комментарий:
Напишите мне, если после меня добавят комментарий
Конфиденциальность: Ваш электронный адрес будет использоваться только для отправки уведомлений.
Анти-спам проверка:
Чтобы избежать проверки в будущем, пожалуйста
войдите
или
зарегистрируйтесь
.
Прокомментировать
Отмена
Ваш ответ
Отображаемое имя (по желанию):
Отправить мне письмо на это адрес если мой ответ выбран или прокомментирован:
Отправить мне письмо если мой ответ выбран или прокомментирован
Конфиденциальность: Ваш электронный адрес будет использоваться только для отправки уведомлений.
Анти-спам проверка:
Чтобы избежать проверки в будущем, пожалуйста
войдите
или
зарегистрируйтесь
.
Ответить
Отмена
Дано ответов:
2
0
голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadSeqIntegerWhile(t->t<>0).Where(t->t.Between(10,99)).ToArray;
if a.Length=0 then Writeln('NO')
else Writeln(a.Average)
end.
Эникей_zn
(
150k
баллов)
28 Май, 18
задать связанный вопрос
комментировать
Ваш комментарий к ответу:
Отображаемое имя (по желанию):
Напишите мне, если после меня будет добавлен комментарий:
Напишите мне, если после меня добавят комментарий
Конфиденциальность: Ваш электронный адрес будет использоваться только для отправки уведомлений.
Анти-спам проверка:
Чтобы избежать проверки в будущем, пожалуйста
войдите
или
зарегистрируйтесь
.
Прокомментировать
Отмена
0
голосов
var
tmp,sum,cnt:real;
begin
while true do begin
read(tmp);
if tmp = 0 then break;
if (abs(tmp) >= 100)or(abs(tmp) <= 9) then continue;<br>sum:=sum + tmp;
cnt:=cnt + 1;
end;
if cnt = 0 then
Writeln('NO')
else
Writeln(sum/cnt);
end.
danulpopov_zn
(
8.8k
баллов)
28 Май, 18
задать связанный вопрос
комментировать
Ваш комментарий к ответу:
Отображаемое имя (по желанию):
Напишите мне, если после меня будет добавлен комментарий:
Напишите мне, если после меня добавят комментарий
Конфиденциальность: Ваш электронный адрес будет использоваться только для отправки уведомлений.
Анти-спам проверка:
Чтобы избежать проверки в будущем, пожалуйста
войдите
или
зарегистрируйтесь
.
Прокомментировать
Отмена
Похожие задачи
Дан массив, содержащий 70 целых чисел из промежутка [-100;100].Опишите на языке...
ПОМОГИИИТЕ ПОЖАЛУЙСТА ! РЕШЕНИЕ ЖЕЛАТЕЛЬНО ФОТКОЙ!
С решением, пожалуйста. Буду очень благодарен! 1. Посчитать в Кбайтах объём объём...
Составить программу Pascal: заданы числа a и b. Определить, эти числа одного или разных...
Помогите с первым заданием программировать нужно на языке PascalABC