Помогите!!Пожалуйста!!даю 50 баллов!!! Написать программу которая просит ввести 10 чисел...

0 голосов
13 просмотров

Помогите!!Пожалуйста!!даю 50 баллов!!!

Написать программу которая просит ввести 10 чисел и находит сумму всех чисел,которые больше 0 из ряда введенных
Для pascal ABC


Информатика (573 баллов) | 13 просмотров
0

Все числа вводятся в одной строке или каждое в своей?

0

Каждое в своей

Дано ответов: 2
0 голосов
Правильный ответ

Program abc;
var a, summa:integer;
begin
summa:=0;
writeln('Введите 10 чисел');
for i:integer:=1 to 10 do begin
 readln(a);
if a>0 then summa:=summa+a;
end;
writeln(summa)
end.

(499 баллов)
0 голосов

// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
var a:= ReadArrInteger(10);
Writeln(a.Where(t->t>0).Sum);
end.
Пример:
0
12
2
3
5
6
1
2
5
6
42

(8.8k баллов)