Напишите программу ** языке паскаль По алгоритму Алг Нач вещ p,s P:=2 S:=0 Нц P:=p*1.5...

0 голосов
178 просмотров

Напишите программу на языке паскаль
По алгоритму

Алг
Нач вещ p,s
P:=2
S:=0
Нц
P:=p*1.5
S:=s+p
Кц при p>5
Вывод S
Кон

Только на стандарте школьной программы.


Информатика (607 баллов) | 178 просмотров
0

Тогда формулировка "по Угриновичу" Вас устроит?

0

Согласен,а мне проще самому написать программу, чем обьяснять то,чему меня учили.

0

хотя,если честно,то я сегодня ожидал увидеть ответ типа "с какого бодуна я должен писать сам по себе?!",так как очень часто такое встречал на разнообразных форумах))

0

Не интернет,в обычной жизни.

Дан 1 ответ
0 голосов
Правильный ответ

Program Test;

Var S, P: real;

Begin

P := 2;
S := 0;

Repeat
P := P * 1.5;
S := S + P;

Until (P > 5);

Writeln('S = ', S);

End.


image
(13.4k баллов)
0

А что на изображении?я просто с мобильной версии.

0

Там сфотонрафирован код и его исполнение

0

Спасибо!!

0

На какой программе проверял?