Помогите написать программу

0 голосов
18 просмотров

Помогите написать программу


image

Информатика (132 баллов) | 18 просмотров
Дан 1 ответ
0 голосов

Const arr_size = 5;//длина массива,можно менять
var
arr:array [1..arr_size] of Integer;
var x:Integer;
var find:boolean;
begin
randomize;
WriteLn('Введите X');
Read(x);
for var i:= 1 to arr_size do
arr[i]:= Random(6);
WriteLn('Массив:');
WriteLn(arr);
WriteLn('Что ищем:');
WriteLn(x);
for var i:= 1 to arr_size do
if arr[i] = x then
begin
if find <> true then
Write('Нашли: ');
find:= true;
Write('arr['+i+']='+x+' ');
end;
if find <> true then
WriteLn('Ничего не нашли.');
end.

(614 баллов)