Паскаль Напишите программу, которая выводит ** экран массив В в одну строку и определяет...

0 голосов
55 просмотров

Паскаль
Напишите программу, которая выводит на экран массив В в одну строку и определяет количество четных и количество нечетных элементов.


Информатика (63 баллов) | 55 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var b:=ArrRandom(ReadInteger('n='),-50,50); b.Println;
  Writeln('Четных элементов ',
      b.Where(t->t.IsEven).Count,
      ', нечетных ',
      b.Where(t->t.IsOdd).Count)
end.

Пример
n= 20
-18 -1 48 -31 -18 -34 -42 20 -30 14 -16 45 50 0 -18 39 45 19 -10 16
Четных элементов 14, нечетных 6
(150k баллов)