Составить программу, выводящую числа от 70 до 100, которые нечетные и делятся ** 3. Найти...

0 голосов
46 просмотров

Составить программу, выводящую числа от 70 до 100, которые нечетные и делятся на 3. Найти их сумму и количество этих чисел.


Информатика (47 баллов) | 46 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.3

begin
  var a:=Range(70,101).Where(i->(i mod 2=1)and(i mod 3=0)).
     ToArray.Println;
  writeln('s = ',a.Sum,' k = ',a.Count);
end.

Результат:
75 81 87 93 99
s = 435 k = 5

(194k баллов)
0 голосов

C++
//g++  5.4.0

#include
using namespace std;

int main()
{
    size_t sum = 0, count = 0;
    for (size_t i = 71, c = 1; i <= 100; i += 2, ++c) {<br>        cout << i << " ";<br>        sum += i;
        count = c;
    }
    cout << endl << sum << " / " << count << endl;<br>}

(4.2k баллов)