Напишите программу,которая соединяет четыре введенных слова в однy строку и выводит их...

0 голосов
40 просмотров

Напишите программу,которая соединяет четыре введенных слова в однy строку и выводит их три раза, причём в первой строке ставится в конце ?, во второй ??, а в третьей ???
Pascal.


Информатика (12 баллов) | 40 просмотров
0

Что становится в конце и тд непонятно

0

в конце ставятся вопросительные знаки,ало.

0

помогите,пожалуйста.

0

Например первое слово будет Н торое О третье Р а четвёртое А = НОРА И получает 1раз НОРА? 2раз НОРА?? и третий раз НОРА ???

0

так ?

0

Да.

Дан 1 ответ
0 голосов

Program p1;
uses crt;
var s,s2,s3:string;
i,a:integer;
begin
read(s);
for i:=1 to 4 do begin
 a:=Pos(' ',s);
 s2:=Copy(s,1,a-1);
 delete(s,1,a);
 s3:=s3+s2;
 end;
 s3:=s3+s;
 for i:=1 to 3 do begin
 s3:=s3+'?';
 writeln(s3);
 end;
 end.

(324 баллов)