Помогите.пожалуйста Написать программу ** языке Паскаль для решения задачи: По данным...

0 голосов
23 просмотров

Помогите.пожалуйста
Написать программу на языке Паскаль для решения задачи: По данным сторонам прямоугольника вычислить его периметр, площадь и длину диагонали. Входные данные задать самостоятельно. Для проверки подготовить код программы и результаты ее работы.


Информатика (32 баллов) | 23 просмотров
Дан 1 ответ
0 голосов

Var
a,b,S,P:Integer;
d:real;
Begin
Writeln('Введите стороны прямоугольника');
Read(a,b);
P:=2*(a+b);
S:=a*b;
d:=sqrt(sqr(a)+sqr(b));
Writeln('Периметр=', P);
WriteLn('Площадь=', S);
WriteLn('Диагональ=', d:6:2);
End.

(160 баллов)