Написать программу ** Pascal. Ввести 10 случайных чисел и посчитать количество чётных и...

0 голосов
75 просмотров

Написать программу на Pascal.
Ввести 10 случайных чисел и посчитать количество чётных и нечётных .


Информатика (23 баллов) | 75 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,-50,50); a.Println;
  var k:=a.Where(t->t.IsOdd).Count;
  Writeln('Четных чисел ',k,', нечетных ',10-k)
end.

Пример
-45 -50 -29 12 35 -50 -33 -16 50 -24
Четных чисел 4, нечетных 6
(150k баллов)
0

Нет, нужно чтобы я ввела числа

0

У вас написано СЛУЧАЙНЫХ ЧИСЕЛ. Учитесь правильно формулировать

0

Чтобы ввести числа, замените всю первую строчку следующим текстом: var a:=ReadArrInteger(10);

0

Спасибо!

0

Пожалуйста

0

Ну или var a:=ReadArrReal(10); чтобы и нецелые числа вводить.

0

Только лучше этого не делать, потому что у нецелых нельзя определить четность и нечетность ))))