Нужна помощь с программированием в Pascal. Напишите программу ** задачу: "Дано...

0 голосов
46 просмотров

Нужна помощь с программированием в Pascal.
Напишите программу на задачу:

"Дано действительные числа a,b,c . Если a>b>c , то числа оставить без изменений, в противоположном случае все числа заменить на их квадраты"


Информатика (19 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

1. Современное решение

begin
  var (a,b,c):=ReadReal3;
  if (a>b) and (b>c) then else (a,b,c):=(a*a,b*b,c*c);
  Println(a,b,c)
end.

Пример
15.8 4.9 13
249.64 24.01 169

2. А так, увы, все еще учат писать во многих школах...

program Toska; 

var
  a,b,c:real;

begin
  Read(a,b,c);
  if not ((a>b) and (b>c)) then begin
    a:=a*a; b:=b*b; c:=c*c
    end;
  Writeln(a,' ',b,' ',c)
end.
(150k баллов)