Написать программу в Pascal по 2 способам repeat и while.Сделать блок-схему

0 голосов
46 просмотров

Написать программу в Pascal по 2 способам repeat и while.Сделать блок-схему


image

Информатика (100 баллов) | 46 просмотров
Дан 1 ответ
0 голосов

На TP7

var
x,i:integer;
s:real;
begin
    write('vvedite x: ');
    readln(x);
    i:=1;
    repeat 
         i:=i+1; 
          s:=s+i*cos(i*x);
    until i=15;
 writeln('s=',s);
end.


var
x,i:integer;
s:real;
begin
  write('vvedite x: ');
  readln(x);
   i:=1;
   while i<16 do<br>        begin 
           i:=i+1; 
           s:=s+i*cos(i*x);
         end;
    writeln('s=',s);
end.

Имейте в виду, что алгоритмы построены по коду автоматически, и препод это сразу увидит.


image
(572 баллов)