Нужно написать программу ** Паскале: В матрице размера M×N положительные элементы...

0 голосов
70 просмотров

Нужно написать программу на Паскале: В матрице размера M×N положительные элементы заменить единицей. Создание и вывод матриц оформить в виде процедур.


Информатика (22 баллов) | 70 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.4.0, сборка 1675 от 12.06.2018
Внимание! Если программа не работает, обновите версию!

procedure MatrixCreate(m,n:integer; var A:array[,] of integer);
begin
  A:=MatrRandom(m,n,-50,50);
end;

procedure MatrixOutput(A:array[,] of integer);
begin
  A.Println(4)
end;

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
  var a:array[,] of integer;
  MatrixCreate(m,n,a);
  Writeln('*** Исходная матрица ***');
  MatrixOutput(a);
  a.Transform(t->t>0?1:t);
  Writeln('*** Полученная матрица ***');
  MatrixOutput(a);
end.

image
(150k баллов)
0

Почему-то на 3 строчке ошибка... Program2.pas(3) : Неожиданный символ ' '

0

Браузер Ваш некорректно что-то вставил. Удалите первый и последний символы строки и наберите вручную.

0

Program1.pas(10) : Встречено '(', а ожидался идентификатор

0

Вы в какой версии запустить пытаетесь? Там же написано в первой строке...

0

сделала как написали, набрала вручную,теперь ошибка на 10ой...

0

версия 3.2 сборка 1361 (1)

0

1361 (13.12.2016)

0

А указана какая версия? И что ниже написано во второй строке? ОБНОВИТЬ!

0

Вам лень было прочитать первые две строки ответа и Вы уже четверть часа ищете несуществующие ошибки.