Написать программу, которая вычисляет, сколько раз введенное с клавиатуры число...

0 голосов
85 просмотров

Написать программу, которая вычисляет, сколько раз введенное с клавиатуры число встречается в линейном массиве из 10 случайных чисел. Pascal ABC


Информатика (12 баллов) | 85 просмотров
Дано ответов: 2
0 голосов

Var
  a:array[1..10] of integer;
  b,i,k:integer;
begin
  Randomize;
  Write('Введите количество элементов в массиве: ');
  for i:=1 to 10 do
  begin
    a[i]:=Random(21)-10;
    Write(a[i],' ')
    end;
  Writeln;
  Write('Какое число искать? ');
  Readln(b);
  k:=0;
  for i:=1 to 10 do
    if a[i]=b then Inc(k);
  Writeln('Число встречается ',k,' раз')
end.

(2.0k баллов)
0 голосов

Var
  a:array[1..10] of integer;
  b,i,k:integer;
begin
  Randomize;
  Write('Введите количество элементов в массиве: ');
  for i:=1 to 10 do
  begin
    a[i]:=Random(21)-10;
    Write(a[i],' ')
    end;
  Writeln;
  Write('Какое число искать? ');
  Readln(b);
  k:=0;
  for i:=1 to 10 do
    if a[i]=b then Inc(k);
  Writeln('Число встречается ',k,' раз')
end.

Подробнее - на Znanija.com - znanija.com/task/29303328#readmore

(52 баллов)