ИнформатикаБуду благодарен за помощь.Задача по информатике с сайта acmp https://acmp.ru/...

0 голосов
329 просмотров

Информатика
Буду благодарен за помощь.
Задача по информатике с сайта acmp https://acmp.ru/
Три толстяка
(Время: 1 сек. Память: 16 Мб Сложность: 7%)
Три толстяка решили поспорить: кто из них самый тяжелый. После взвешивания оказалось, что их масса соответственно M1, M2 и M3 килограмм. Считается, что масса толстяка должна быть не менее 94 и не более 727 килограмм.

Помогите определить массу самого тяжелого из них, либо выяснить, что была допущена ошибка при взвешивании.

Входные данные
Входной файл INPUT.TXT содержит три целых числа M1, M2 и M3, разделенные пробелом. Все числа целые и не превосходят 10 000 по абсолютной величине.

Выходные данные
В выходной файл OUTPUT.TXT выведите массу самого тяжелого толстяка в случае корректного взвешивания, либо слово «Error» в противном случае.

Задача с сайта acmp , пишет ошибка (на 4 тесте) .Что здесь не так?Подскажите пожалуйста. Pascal(Delphi).

program tolstiki;

{$APPTYPE CONSOLE}

uses
SysUtils;

var a,b,c:integer;
begin
read(a,b,c);
if (a<94)or (a>727)or(b<94)or (b>727)or (c<94)or (c>727) then Writeln ('Error')
else if (a>b)and(a>c) then Writeln(a)
else if (b>a)and(b>c) then Writeln(b)
else if (c>b)and(c>a) then Writeln(c);
Readln;Readln;
{ TODO -oUser -cConsole Main : Insert code here }
end.


Информатика (12 баллов) | 329 просмотров
Дан 1 ответ
0 голосов

Во первых условие на вес желательно если не три толстяка а 1000 студентов завести массив их веса а потом с помощью пузырьчатой сортировки только сделать прохождение по массиву одинажды.
в итоге в последнюю я чейку попадает самый большой вес и он выдается на экран
например был массив
[99,167,700,354] а стал массив
[99,167,354,700] в итоге 700 самый большой вес

(582 баллов)
0

мы массивы не проходили

0

ну давай обьясню. массив это ряд переменнвх одного типа например можно сделать з толстяка как var a var b var c а можно завести массив из 3 элементов например var a[1,2,3]
но если у тебя 10000 студентов то ты не будешь создавать 10000 переменных верно?

0

ты создашь массив а из 10000 ячеек но чтобы обращаться к его элементам напиши write a[35] и тебе напишется 35 ячейка например Иваноа