спставьте программу ** языке Pascal: Для ремонта кабинета шириной а метров, длиной b...

0 голосов
25 просмотров

спставьте программу на языке Pascal:

Для ремонта кабинета шириной а метров, длиной b метров, высотой h метров необходимо купить в магазине обоев. Площадь окон и дверей не учитывать. Известна стоимость одного рулона (86 рублей) обоев длиной 12 м и шириной 0,6 м. Составьте программу определяющую, какая сумма необходима для покупки обоев.


Информатика (96 баллов) | 25 просмотров
Дан 1 ответ
0 голосов

Program olraisinsss;
const n=86; z=12; c=0.6;
var a,b,h,p1,sum:integer;   
     p2:real;
begin
write('a=');read(a);
write('b=');read(b);
write('h=');read(h);
p1:=4*(b+h)+4*(a+h);

while p2p2:=p2+2*(z+c);
sum:=sum+1;
end;
writeln('Price=',sum*n);
end.

(1.6k баллов)