Напишите программу, которая получает два целых числа и находит их произведение, не...

0 голосов
138 просмотров

Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными. Пример: Введите два числа: 10 -15 10*(-15)=-150 Это цикл с условием ( while)ПАСКАЛЬ Помогите пожалуйста Заранее спасибо


Информатика (519 баллов) | 138 просмотров
0

Не, ну ты вовремя написал. Я уже сделал программу, а ты Паскаль.

0

Не знаю,дали такое задание

0

Раз можете сделать, расскажите, как организуете вывод.

0

Я Вам вопрос задал О ВЫВОДЕ, о представлении результатов.

0

я могу его сделать через for а через цикл while нет

0

А иначе все сводится к тривиальной подсказке, а это противозаконно. Попробуйте понять.

0

А вот если Вам дали задание, а Вы его осмыслили, как-то проработали и попросили помочь - это другое дело.

0

Давайте нам координаты того, кто задание Вам выдал и мы просто сразу ответ туда отправим.

0

Задания тут Вы даете. И чем Вы раньше это поймете, тем лучше для Вас. Если Вы просто сюда переписываете задание, которое дали Вам, а потом наш ответ назад - то Вы просто лишнее звено в цепочке.

0

Задание - это не интересно. Интересует Ваш ответ на поставленный вопрос.

Дан 1 ответ
0 голосов

javascript:var a = parseInt(prompt()), b = parseInt(prompt()), c = 0, сч = 0; while (сч < Math.abs(b)) { c += a; сч++; } if (b < 0) c = -c; alert(c);


А вот и Pascal. Надеюсь, не ошибся.


program pr;

var a, b, c, cnt: integer;

begin

 a := readln();

 b := readln();

 c := 0;

 cnt = 0;

 while (c < abs(b)) begin

   c := c + a;

   cnt := cnt + 1;

 end;

 writeln(c);

end.

   

(654k баллов)
0

Обычно когда дают пример, там дают и формат вывода.

0

Так принято

0

В общем, для меня тут больше дел нет)

0

Так тогда бы и сказала, что достаточно дать число. Но ведь молчит, тупо твердя, что "так в задании, зеать ничего не знаю".

0

Но если сказано "вывод 10*(-15)=-150" - у меня вопрос возникает.

0

Можно простить.

0

Она просто засунула пояснение (мол, можно на отрицательное умножать) в строку, где обычно есть ответ.

0

Т .е. если сказано "ввод 10 -15, вывод -150" - вопроса нет.

0

Да тут очевидно, что вывод - одно число.

0

Ну хочется ему всё выражение, пусть будет всё. Ну да Бог с ним. Логику я ему расписал, дальше пусть сам форматирует.