Помогите пожалуйста. даю 21б. информатика. программа Паскаль. Составить программу...

0 голосов
67 просмотров

Помогите пожалуйста. даю 21б. информатика. программа Паскаль. Составить программу вычисления, W= B + A/ C+1A - сумма положительных элементов массива.C - произведение элементов массива с нечетными номерамиПолученные значения элементов A,B,C,W вывести на печать.(см. картинку)


image

Информатика (101 баллов) | 67 просмотров
Дан 1 ответ
0 голосов

const n=10;

var m:array [1..n] of integer;

i,a,b,c:integer;

w:real;

begin

c:=1;

write('Массив: ');

for i:=1 to n do

begin

m[i]:=random(19)-9;

if m[i] > 0 then a:=a+m[i];

if i mod 2 <> 0 then c:=c*m[i];

write(m[i],'  ')

end;

writeln;

b:=m[1];

for i:=2 to n do if m[i] < b then b:=m[i];

w:=b+a/(c+1);

writeln('Сумма положительных элементов массива A = ',a);

writeln('Наименьший элементов массива B = ',b);

writeln('Произведение элементов массива с нечетными номерами C = ',c);

writeln('W = ',w:0:3);

end.

(1.7k баллов)