Нужно написать программу в паскале Возвести в квадрат элементы, не превосходящие по...

0 голосов
27 просмотров

Нужно написать программу в паскале Возвести в квадрат элементы, не превосходящие по модулю введенное с клавиатуры число R.


Информатика (67 баллов) | 27 просмотров
Дано ответов: 2
0 голосов

var

 r, i: integer;

 

begin

 readln(r);

 for i := 0 to r do write(power(i, 2), ' ');

end.

(574 баллов)
0 голосов

const n=10;

var a:array[1..n] of integer;

i,r: integer;

begin

write (' Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(41)-20;

write (a[i]:3,' ')

end;

writeln;

write ('Введите число: ');

readln (r);

write ('Преобразованый массив: ');

for i:=1 to n do

begin

if abs(a[i]) <= r then a[i]:=a[i]*a[i];</p>

write (a[i]:3,' ')

end

end.

(1.7k баллов)